Disco 3 TDV6 shudder at certain speeds

Calls for help, Problems, Breakdowns, Mechanical & Electrical
Post Reply
SchyffS
Forum Contributor
Posts: 2
Joined: Tue Jan 14, 2020 4:16 pm
Car Details: 2007 2.7 TDV6

Disco 3 TDV6 shudder at certain speeds

Post by SchyffS » Mon Feb 10, 2020 2:34 pm

Hi

I have a light engine shudder, feels like an intermittent loss of power at specific speeds. First at approximately 80km/h and then again at 120km/h.
It’s similar to when there is a loss of fuel.

Vehicle starts first time from cold.
Idle does feel slightly rough both warm or cold.
My injector imbalance are all in spec on idle (above 900) when warmed up and they all even out at 1000 during driving.
I have replaced the oil temperature sensor.
I have cleaned both the MAP AND MAF sensors.

On startup idle:
Image

Image
Image

Engine warmed up and idling:
Image

Image

Image

Any advise on fuel pump voltages and pressures?
What can the fault be?



Sent from my iPhone using Tapatalk
Last edited by SchyffS on Mon Feb 10, 2020 2:34 pm, edited 4 times in total.



User avatar
anglefire
Site Admin
Posts: 19207
Joined: Sat May 15, 2010 8:01 pm
Winner: Club Member of Year 2012 & 13
Car Details: Skoda Superb SE L Ex
Member Since: 17 May 2010
Location: Solihull, West Midlands
Contact:

Re: Disco 3 TDV6 shudder at certain speeds

Post by anglefire » Thu Feb 13, 2020 7:06 pm

Firstly, I would say 900 was a little low - and 1000 when driving is normal - the readings mean nothing above idle.

But you really need someone like Bodsy as he has a lot more experience and knowledge.


Mark

Waeco CFX 40
1977 Triumph Spitfire 1500
2006 disco3 SE. Gone but not forgotten.
BMW 530d M Sport Touring. Gone
Member of Admin team and :ugeek:
Disco3Club Photos: Here

Post Reply